源氏物語の世界 再編集版

源氏物語の世界　再編集版　ＨＴＭＬヘルプ形式

このページは高千穂大学の渋谷教授が公開しているホームページ「源氏物語の世界」を再編集したページです。注釈が読みやすくなった、本文と現代語訳を対照表示できる、目次が使いやすくなったなどの特徴があります。

本サイト内に掲載されている源氏物語の本文、注釈、現代語訳、ローマ字版などは、すべて、渋谷教授によるものです。渋谷教授のご好意により、本サイトでの再編集した形での転載を許可していただきました。

再編集版について

この再編集版には、以下のような特徴があります。

特徴 説明
注釈を読みやすく
しました。 		渋谷教授は全部で22065件の注釈を書いてくれています（2003年５月現在）。しかし、本文と注釈は別のページにあり、しかもリンクされていないので、これを照らし合わせてオンラインで読むのはかなり苦労します。再編集版では、その注釈のほとんどについて本文との間で相互リンクしました。

また、本文のリンクの上でマウスを止めることで、これらをツールチップで表示させることもできます。短い注釈ならツールチップ表示だけで足りるので便利です。

たとえば、桐壺の帖の最初の行は以下のようになっています。

   いづれの御時にか、 女御、更衣あまた さぶらひたまひけるなかに、 いとやむごとなき際にはあらぬが、すぐれて 時めきたまふありけり。

なお、出典と校訂についても、注釈と同様にツールチップで表示できるようにしてあります。
本文と現代語訳等を
対照表示できます。

その表示形式は簡単
に変更できます。 		本文・現代語訳・ローマ字版の３つを行単位に対照できるように配置しました。たとえば、桐壺の帖の最初の行は以下のようになります。
1.1.1 　 いづれの御時にか、 女御、更衣あまた さぶらひたまひけるなかに、 いとやむごとなき際にはあらぬが、すぐれて 時めきたまふありけり。
           どの帝の御代であったか、女御や更衣が大勢お仕えなさっていたなかに、たいして高貴な身分ではない方で、きわだって御寵愛をあつめていらっしゃる方があった。
         Idure no ohom-toki ni ka, nyougo, kaui amata saburahi tamahi keru naka ni, ito yamgotonaki kiha ni ha ara nu ga, sugurete tokimeki tamahu ari keri.

しかし、この例のように本当に３つとも対照表示させると、よほど大きなディスプレイでない限り、窮屈な印象を受けます。そこで、ページの先頭に表示設定のチェックボックスを設けて、必要なものだけを簡単に取捨選択して表示できるようにしてあります。

たとえば、上図のように、本文と現代語訳を選択して番号とローマ字版を非選択にすると、桐壺の帖の最初の行は以下のように表示されます。（初期状態ではこの状態になっています。）

   いづれの御時にか、 女御、更衣あまた さぶらひたまひけるなかに、 いとやむごとなき際にはあらぬが、すぐれて 時めきたまふありけり。
           どの帝の御代であったか、女御や更衣が大勢お仕えなさっていたなかに、たいして高貴な身分ではない方で、きわだって御寵愛をあつめていらっしゃる方があった。

この表示設定はcookieに３０日間保存されます。一度、好みの表示設定に設定しておけば、次に設定変更する必要が生じるまで、再設定する必要はありません。

目次を使いやすく
しました。

 左のフレームのツリービュー目次を使って、任意の帖･章・段落に直接アクセスできます。

また、各帖には、別に細目次のページがあり、和歌による目次（注釈付！）もあります。

HTMLヘルプ形式の再編集版について

再編集版をＨＴＭＬヘルプ形式に変換したものをダウンロードすることもできます。HTMLヘルプはMicrosoft Office(Word、Excel等)で採用されているヘルプファイルの形式です。

この形式は、高速な全文検索に特徴があります。再編集版では、１ページに本文、注釈・出典・校訂、現代語訳、ローマ字版が入っているので、そのすべてを対象として全文検索されます。この結果、本文だけの全文検索とはまた違った検索結果が得られるので、使い方によっては、面白い結果が得られるのではないでしょうか。

例えば、「蓬莱」を全文検索すると、帚木、絵合、胡蝶、宿木の４帖が出てきますが、このうち、本文でヒットするのは帚木、絵合、宿木の３帖です。胡蝶では本文には現れないのですが、注釈・出典・現代語訳でヒットします。「亀の上の山」というのが遠まわしに蓬莱山を指していることが注釈と出典で説明され（下図）、それを受けて現代語訳では「亀の上の山」を「蓬莱山」と訳しているからです。

ただし、この検索機能は、ひらがなをキーにして検索しようとすると、問題があるようです。この点については、楽天広場の私のページの ２００３年９月７日の日記で説明していますので、そちらを参照してください。

なお、HTMLヘルプ形式の再編集版と、通常のHTML形式の再編集版の相違点は以下のとおりです。

HTML形式 HTMLヘルプ形式 説明
表示速度 ○ ◎ HTMLヘルプはあらかじめコンパイルされているので、HTMLよりも高速な表示が可能です。
全文検索 × ○ HTMLヘルプファイルには全文検索インデックスが含まれているので、非常に高速な全文検索ができます。
表示設定の保存 ○ × HTML形式では表示設定はcookieに約１ヶ月間保存されます。その間は最後の設定が残っています。しかし、ＨＴＭＬヘルプではcookieが使えないので、ページを読み込むたびに初期設定値に戻ってしまいます。

ライセンスについて

この再編集結果、および、再編集プログラムは、GPL（GNU General Public License Version 2）にしたがうフリーソフトとします。オリジナルの「源氏物語の世界」と同じライセンスも考えましたが、その主旨はGPLと同じと思えるので、一般的なGPLを採用させていただきます。

フリーソフトですので、GPLに従う限り、自由にコピーや変更・再配布ができます。

反面、保証がありません。メールなどでご連絡いただければ可能な限り対応いたしますが、対応を保証することはできません。

源氏物語の世界： Copyright (C) 1996,2006 渋谷栄一
再編集版： Copyright (C) 2003,2009 宮脇文経